Your Airline

busyLoading Poll...

Latest Posts

More Topics »

Make a Donation

Do you like the program? Why not donate some money to maintain and improve this website and the program?

Enter Amount:



Welcome, Guest
Username Password: Remember me

Other error in 3.4.4340.0
(1 viewing) (1) Guest
Problem Reporting

TOPIC: Other error in 3.4.4340.0

Other error in 3.4.4340.0 3 years, 6 months ago #2101

  • kaer
  • OFFLINE
  • Posts: 18
Hi Nils.

Just FYI. (Know you are busy - so sorry in advance.)

Ran a download and an export of the missus' roster.
At some point during the export a pop-up "Bubble" came up in the RH lower corner saying some kind of error had occurred during export.
R2O seemed to run fine watching the app.

When it was done, I switched users to "me" and clicked download.
It came up and said "Part 3/3- 1% " and hung. (think there was some kind of leftover from the missus roster as that was in three parts.)

Clicked cancel, closed the app, reopened the app, only to find it had now "dumped" my user details,
Whilst wanting to re-insert my details, I found "Download options" greyed, so I could not re-enter my details !

Discovered a work-around as when I clicked download roster, it opened up "Download options" prompting me to insert my details.....

Downloaded the roster - and export seemed fine.

Cheers

Re: Other error in 3.4.4340.0 3 years, 6 months ago #2105

  • Nils
  • OFFLINE
  • Posts: 802
Thanks for the feedback.

Can you look in the error log what the actual error was? It could be with one of the 3 rosters, but Roster2Outlook will than continue with the others, so it might look as if everything was fine, while there was an error in the first roster.

Originally, the download options button was disabled if there was no add-on. I enabled it by default, but thanks to your feedback I thought that maybe changing user would force the software to checks for an add-on again and if it doesn't find one will grey out the button (and I thought also the button, but apparently that stayed enabled). However I just checked the code, and nowhere is this button disabled anymore... I also did some testing with changing users, but the button never greyed out. Maybe it had to do with the error, or with your login details being erased (still!).

I'll do some more testing and let you know if I find anything...
Nils
Follow us on Twitter and Facebook for the latest news and updates!

Re: Other error in 3.4.4340.0 3 years, 6 months ago #2108

  • kaer
  • OFFLINE
  • Posts: 18
Cant look in the log file cause it went alright later.

Today though.......

Ran the missus - OK.

As easyJet last night asked me to change my password, I had to enter the new one.
Only way of getting to the settings is deleting my user as the settings menu is greyed (see pic)
(Just now I figured out to use the Settings button instead.....sigh.....)
Anyway.....

Having entered my details, and chosen my options, click to download I then get
PLEASE ENTER YOUR LOGIN DETAILS (see attached) ??

Seems that selecting when to download from and/or time gives this error ??

Later On I get it sorted by not selecting these, roster downloaded, when trying to export it
I have have to authorise Google again.

And then it hangs.

I then close it reopen, try downloading again, I get the third attachement.

I dont know if some part of the comms need to be flushed now and again ??
Attachments:
Last Edit: 3 years, 6 months ago by kaer. Reason: another jpg

Re: Other error in 3.4.4340.0 3 years, 6 months ago #2116

  • Nils
  • OFFLINE
  • Posts: 802
Thanks for the feedback.

I didn't think of the menu items, but the buttons. I forgot to make them enabled by default. I'll do that today.

I'll have a look at the code again, as I think there is still some checking for add-ons somewhere and that might be the problem of the "Please enter login details".

And very strange that it hangs at 1% but already knows you have no changes...? That's normally not knwo till much later. ANyway, I assume for now the problems just add up and confuse Roster2Outlook. Let me fix the first two things first and than we see if it still hangs and why?

Nils
Follow us on Twitter and Facebook for the latest news and updates!

Re: Other error in 3.4.4340.0 3 years, 6 months ago #2120

Hi Nils
First after starting r2o I get the error password r username would not match. Definitely entered them correctly. Second attempt stops at 1% without errormsg.
Last Edit: 3 years, 6 months ago by philharmony.

Re: Other error in 3.4.4340.0 3 years, 6 months ago #2121

Hi Nils,
Finally I downloaded the latest version what seems working now.
I always used your program via the Browse button, then Get roster.
Till this point it works fine, but as I try to export it to Google Calendar an error msg pops up. I copied it from Debug folder:

2014.12.12. 11:07:30 - 3.4.4340.0:System.IO.FileLoadException: A(z) „System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes” fájl vagy szerelvény, illetve annak egyik függősége nem tölthető be. A megadott szerelvénynév vagy kódbázis érvénytelen. (A kivétel HRESULT-értéke: 0x80131047)
Fájlnév: „System.Core, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e, Retargetable=Yes”
a következő helyen: Google.Apis.Auth.OAuth2.GoogleWebAuthorizationBroker.AuthorizeAsync(ClientSecrets clientSecrets, IEnumerable`1 scopes, String user, CancellationToken taskCancellationToken, IDataStore dataStore)
a következő helyen: Roster2Outlook.frmMain.ReadHTMLBody_Google(Int32 g)
a következő helyen: Roster2Outlook.frmMain.Export()

Hmmm... It is partly in Hungarian...
Do you have any idea, or advise how to solve it?

Thank you:
László
Time to create page: 0.15 seconds